Slack services are sluggish
Incident Report for Nightfall
Resolved
Looks stable
Posted Aug 17, 2023 - 10:59 PDT
Investigating
We are currently investigating the issue
Posted Aug 17, 2023 - 10:11 PDT
This incident affected: Nightfall Console and Nightfall Detection Engine.